股票软件 通达信 大智慧 飞狐 同花顺 东财通 操盘手 指南针 钱龙 券商软件 手机炒股 破解版 证券之星 金融界 分析家 数据下载 数据接口 期货 基金 教程
股票公式 通达信 大智慧 飞狐 同花顺 东财通 | 股票池 通达信 | 大智慧| 股票书籍 | 指标分类 MACD BOLL KDJ OBV CCI RSI DMI SAR VOL DDX DDY DDZ
当前位置:首页 >> 指标公式 >>  通达信公式
股票配资开户注册领取2019元现金
网站SEO排名优化
通达信财神送元宝源码主图股票公式
  • 相关简介: 测试已通过
  • 内容标签: 通达信,股票公式,主图
  • 浏览次数:
  • 运行环境: Win10,Win8,Win7,WinXP
  • 软件作者: 操盘手公式网
  • 软件来源: www.stock87.com
  • 加入时间: 2018-12-01 19:38:09
  • 解压密码: www.stock87.com(请仔细输入!复制无效!)
软件使用说明:(注:已有源码的公式只需要复制源码,不提供文件下载!)

股票公式参数:

RQ1 1990     3000    2010
RQ2  1         12      1
RQ3  1         31       1
RQA  1990       3000    2010}


RQG:=(RQ1-1900)*10000+RQ2*100+RQ3;
AH:=REF(H,BARSLAST(DATE<=RQG )),NODRAW;
高价:=IF(DATE>=RQG AND XG>=1,AH,DRAWNULL),COLOR00FFFF;
RQD:=(RQA-1900)*10000+RQB*100+RQC;

DJ:=REF(L,BARSLAST(DATE<=RQD )),NODRAW;
低价:=IF(DATE>=RQD AND XG>=1,DJ,DRAWNULL),COLORFFFF00;
FU:=C-低价;
低到当前幅度:=FU/低价*100, NODRAW, COLOR00FFFF;
FUGA:=高价-低价;
高到低价幅度%:=FUGA/高价*100,NODRAW,COLOR00FFFF;
AS:=(O+H+L+C)/4;
SY:=EMA(AS,P);
BL:=EMA(AS,17);

低价A:=IF(DATE>=RQD AND GF>=1,DJ*1.03,DRAWNULL),COLOR999999;
低价B:=IF(DATE>=RQD AND GF>=1,DJ*1.05,DRAWNULL),COLOR999999;
低价C:=IF(DATE>=RQD AND GF>=2,DJ*1.08,DRAWNULL),COLOR999999;
低价D:=IF(DATE>=RQD AND GF>=2,DJ*1.13,DRAWNULL),COLOR999999;
低价E:=IF(DATE>=RQD AND GF>=3,DJ*1.18,DRAWNULL),COLOR999999;
低价F:=IF(DATE>=RQD AND GF>=3,DJ*1.25,DRAWNULL),COLOR999999;
低价G:=IF(DATE>=RQD AND GF>=4,DJ*1.34,DRAWNULL),COLOR999999;
低价H:=IF(DATE>=RQD AND GF>=4,DJ*1.37,DRAWNULL),COLOR999999;
DRAWTEXT(ISLASTBAR AND GF>=1,DJ*1.03,'3%'),COLOR208FFF;
DRAWTEXT(ISLASTBAR AND GF>=1,DJ*1.05,'5%'),COLOR208FFF;
DRAWTEXT(DATE<=RQD AND GF>=2,低价C,'8%'),COLOR208FFF;
DRAWTEXT(DATE<=RQD AND GF>=2,低价D,'13%'),COLOR208FFF;
DRAWTEXT(DATE<=RQD AND GF>=3,低价E,'18%'),COLOR208FFF;
DRAWTEXT(DATE<=RQD AND GF>=3,低价F,'25%'),COLOR208FFF;
DRAWTEXT(DATE<=RQD AND GF>=3,低价G,'34%'),COLOR208FFF;
DRAWTEXT(DATE<=RQD AND GF>=3,低价H,'37%'),COLOR208FFF;
STICKLINE(DATE<=RQG,低价,高价,0,0),COLOR00FF00;
STICKLINE(DATE<=RQD,高价,低价,0,0),COLORFF00FF;
Q1:=(低价+(高价 - DJ) * 0.191)/高价;
Q2:=(低价+(高价 - DJ) * 0.382)/高价;
Q3:=(低价+(高价 - DJ) * 0.50)/高价;
Q4:=(低价+(高价 - DJ) * 0.618)/高价;
Q5:=(低价+(高价 - DJ) * 0.809)/高价;
Q6:=(低价+(高价 - DJ) * 0.333)/高价;
Q7:=(低价+(高价 - DJ) * 0.667)/高价;
ZH:=IF(HF,DATE<=RQG,DATE<=RQD),NODRAW;
高价A:=IF(DATE>=RQD AND XG>=2,AH*Q1,DRAWNULL),COLOR007777,DOTLINE;
高价B:=IF(DATE>=RQD AND XG>=2,AH*Q2,DRAWNULL),COLOR007777,DOTLINE;
高价C:=IF(DATE>=RQD AND XG>=2,AH*Q3,DRAWNULL),COLOR007777,DOTLINE;
高价D:=IF(DATE>=RQD AND XG>=2,AH*Q4,DRAWNULL),COLOR007777,DOTLINE;
高价E:=IF(DATE>=RQD AND XG>=2,AH*Q5,DRAWNULL),COLOR007777,DOTLINE;
高价F:=IF(DATE>=RQD AND XG>=2,AH*Q6,DRAWNULL),COLOR007700,LINETHICK3;
高价G:=IF(DATE>=RQD AND XG>=2,AH*Q7,DRAWNULL),COLOR007700,LINETHICK3;
DRAWNUMBER(ZH,高价*Q1*1.008,高价*Q1),COLOR00FFFF;
DRAWNUMBER(ZH,高价*Q2*1.008,高价*Q2),COLOR00FFFF;
DRAWNUMBER(ZH,高价*Q3*1.008,高价*Q3),COLOR00FFFF;
DRAWNUMBER(ZH,高价*Q4*1.008,高价*Q4),COLOR00FFFF;
DRAWNUMBER(ZH,高价*Q5*1.008,高价*Q5),COLOR00FFFF;
DRAWNUMBER(ZH,高价*Q6*0.999,高价*Q6),COLOR00FF00;
DRAWNUMBER(ZH,高价*Q7*1.01,高价*Q7),COLOR00FF00;
SYA:=EMA(AS,P1),LINETHICK2,COLORCCAACC;
LJ2:=(C-LLV(LOW,8))/(HHV(HIGH,8)-LLV(LOW,8))*100;
LJF2:=(EMA(LJ2,3));
低:=18;
DI:=EMA(CLOSE,10) - EMA(CLOSE,22);
XG:=CROSS(LJF2,低);
DRAWICON(XG,L,11);
DRAWNUMBER(ISLASTBAR AND SYA,SYA*1.005,SYA);
BLS:= BL+2.58*STDP(C,20);
BL2:= BL+1.96*STDP(C,20);
DRAWICON(CROSS(H,BLS),H,2);

DRAWTEXT(CROSS(H,BL2),H*1.007, '归去'),COLOR80FFFF;
DRAWNUMBER(ISLASTBAR AND BL,BL*1.005,BL);
XGM:=CROSS(SY,BL);
DRAWICON(CROSS(C,BL) AND BL>REF(BL,1) AND DI>REF(DI,1),L,9);

DRAWTEXT(CROSS(C,BL) AND BL>REF(BL,1) AND DI>REF(DI,1) ,LOW*0.97,'★财神'),COLOR80FFFF;

LC := REF(CLOSE,1);
RSI1:=SMA(MAX(CLOSE-LC,0),6,1)/SMA(ABS(CLOSE-LC),6,1)*100;
GB:=IF(RSI1>76,H*1.001,DRAWNULL),CIRCLEDOT,LINETHICK3,COLORFFFF00;
GBB:=IF(RSI1>80,H*1.002,DRAWNULL),CROSSDOT,LINETHICK3,COLOR0000FF;


低点:IF(CURRBARSCOUNT<=N, CONST(IF(ISLASTBAR=1,LLV(L, BARSLAST(CURRBARSCOUNT=45)),1)),DRAWNULL),COLORRED,LINETHICK3;
L45:=CONST(LLVBARS(L,45))+1=CURRBARSCOUNT;
DRAWICON(L45,低点,34);
止损位:=IF(CURRBARSCOUNT<=N, CONST(IF(ISLASTBAR=1,LLV(低点*(100-承担风险)/100, BARSLAST(CURRBARSCOUNT=45)),1)),DRAWNULL),COLORFF8000,LINETHICK3;
止损幅度:=((低点-低点*0.01)/C-1)*100;


{
请设置计算参数:
时间高定位: PARAM#0 (调整年度)
时间高定位: PARAM#1 (调整月份)
时间高定位: PARAM#2 (调整日期)
时间低定位: PARAM#3 (调整年度)
时间低定位: PARAM#4 (调整月份)
时间低定位: PARAM#5 (调整日期)
调整数值1-2:: PARAM#6 显示高低点线及黄金分割线
调整数值0-1:: PARAM#7 调整前后低点转换显示数值
调整数值0-5:: PARAM#8 (显示百分比涨幅度线)
调整数值1-255:: PARAM#9 任意均价线与17EMA间色带
调整数值1-255:: PARAM#10 (显示任意均价线)};


压力:=MA(REF(HHV(C,30),1),2),COLOR00FF00;
支撑:=MA(REF(LLV(C,30),1),2),COLOR0000FF;
中:(MA(C,3)+MA(C,6)+MA(C,12)+MA(C,24))/4,COLORFF0000,LINETHICK2;
IF(中>=REF(中,1), 中 ,DRAWNULL),LINETHICK2,COLOR00FFFF,;
上:=BBI+3*STD(BBI,10),COLOR00FF00,CIRCLEDOT;
下: BBI-3*STD(BBI,10),COLOR0000FF,CIRCLEDOT;
安全:=MA(C,30),CIRCLEDOT,COLORFF00FF;
TJ1:=下*1.05>中 AND 中*1.05>上 AND 中>=REF(中,1) AND REF(中,1)>=REF(中,2);
TJ2:=LLV(REF(VOL,1),60);
VAR91:=REF(V,1)+REF(V,2)+REF(V,3)+REF(V,4)+REF(V,5);
VAR92:=VAR91/5;
LB:=V/VAR92;
TJ8:=C>LLV(LOW,120)*1.38;
VAR2:=(HIGH - LOW);
VAR3:=ABS((OPEN - CLOSE));
VAR4:=(HIGH - IF((CLOSE > OPEN),CLOSE,OPEN));
VAR5:=(IF((CLOSE > OPEN),OPEN,CLOSE) - LOW);
VAR6:=((VAR3 / VAR2) * VOL);
VAR7:=((VAR4 / VAR2) * VOL);
VAR8:=((VAR5 / VAR2) * VOL);
GG:=(VAR6 >= VAR7) AND (VAR6 >= VAR8) AND (CLOSE > OPEN);
TJ3:=LB>2 OR VOL/REF(VOL,1)>2 AND GG;
WLT1:=EMA(C,3);
WLT2:=EMA(C,5);
WLT3:=EMA(WLT2,5);

QQ:= C<上;
MM:=WLT1<REF(WLT1,1);
DD:=QQ AND MM;
TJ6:=COUNT(DD,7)=1;
TJ7:=C<LLV(LOW,250)*2.1;
XG1:=FILTER(TJ1 AND TJ7 AND TJ3,5) AND C<支撑*1.13;
DRAWICON(XG1,L*0.99,23);
DRAWICON(TJ6 AND MM AND TJ8 AND 上>中*1.1,HIGH*1.01,19);
TJ81:=中>=REF(中,1) AND LAST( 中<=REF(中,1),8,1) AND CROSS(C,中) AND C<支撑*1.13;
TJ82:=中>=REF(中,1) AND LAST( 中<=REF(中,1),5,1) AND CROSS(C,中) AND C<HHV(H,55)*0.72 AND C<支撑*1.13;
DRAWICON(TJ81,LOW*0.98,26);
DRAWICON(TJ82,LOW*0.96,25);
DRAWTEXT(TJ82 OR TJ81,L*0.99,'↖送元宝'),COLOR00FFFF;

下载链接:(下载本站资源请点击下面进入下载页“蓝色图标”)
官方千人交流微信群1:antu1688
官方千人交流微信群2:1500113880



关于我们- 广告合作- 下载声明- 下载帮助- 网站地图- 网站XML- 必应XML- 谷歌XML- 网站TXT- 友情链接- 加入收藏

操盘手公式网   Copyright © 2010-2018   stock87.com™, All Rights Reserved.  浙ICP备17017803号
   免责声明:本站所有信息均免费。所有广告、涉及到的链接,如遇收费行为,均与本站无关!请股友自辨真假.
    本站内容为经验总结,部分源自网络,若无意侵犯了您的版权,请联系我站删除. 广告投放QQ:69948046.


浙ICP备17017803号
微信公众号 回顶部
关闭
关闭
关闭
关闭