股票软件 通达信 大智慧 飞狐 同花顺 东财通 操盘手 指南针 钱龙 券商软件 手机炒股 破解版 证券之星 金融界 分析家 数据下载 数据接口 期货 基金 教程
股票公式 通达信 大智慧 飞狐 同花顺 东财通 | 股票池 通达信 | 大智慧| 股票书籍 | 指标分类 MACD BOLL KDJ OBV CCI RSI DMI SAR VOL DDX DDY DDZ
当前位置:首页 >> 指标公式 >>  通达信公式
股票配资开户注册领取2019元现金
股票配资开户送2019元
黄金分割趋势主图通达信源码
  • 相关简介: 测试已通过
  • 内容标签: 黄金分割,趋势主图,通达信源码
  • 浏览次数:
  • 运行环境: Win10,Win8,Win7,WinXP
  • 软件作者: 操盘手公式网
  • 软件来源: www.stock87.com
  • 加入时间: 2019-09-10 08:53:26
  • 解压密码: www.stock87.com(请仔细输入!复制无效!)
软件使用说明:(注:已有源码的公式只需要复制源码,不提供文件下载!)

黄金分割趋势主图通达信源码

{网均线}
网1:=EXPMA(C,5),COLORYELLOW;
网12:EXPMA(C,12),COLORGRAY,LINETHICK3;
网2:=EXPMA(网1,2);
网3:=EXPMA(网2,2);
网33:EXPMA(CLOSE,33),COLORFF00FF,LINETHICK4;
TJ1A:IF(网1>网2,网1,网2),COLORLICYAN;
TJ2A:IF(网1>网3,网1,网3),COLORGREEN;
TJ3A:网1,COLORYELLOW,LINETHICK2;
{QS}
网A:=EXPMA(CLOSE,5),COLORWHITE;

网B:=EXPMA(CLOSE,33),COLORFF00FF,LINETHICK3;

IF(网B<REF(网B,1),网B,DRAWNULL),COLOR00FF00,LINETHICK3;
IF(网B<REF(网A,1),网A,DRAWNULL),COLORWHITE,LINETHICK1;
IF(网1<REF(网B,1),网A,DRAWNULL),COLORGREEN,LINETHICK1;

日:=50;昨前:=3;
高1:=REF(HHV(H,日),昨前);
低1:=REF(LLV(L,日),昨前);
H1:=高1-(高1-低1)*0.191;
H2:=高1-(高1-低1)*0.382;
H3:=高1-(高1-低1)*0.5;
H4:=高1-(高1-低1)*0.618;
H5:=高1-(高1-低1)*0.809;
L1:=低1+(高1-低1)*1.191;
L2:=低1+(高1-低1)*1.382;
L3:=低1+(高1-低1)*1.5;
L4:=低1+(高1-低1)*1.618;
L5:=低1+(高1-低1)*1.809;
短压:REFDATE(高1,DATE),COLORGREEN,LINETHICK1;
支撑19.1%:REFDATE(H1,DATE),COLORYELLOW;
支撑38.2%:REFDATE(H2,DATE),COLORMAGENTA;
支撑50%:REFDATE(H3,DATE),COLORLIGRAY;
支撑61.8%:REFDATE(H4,DATE),COLORWHITE,LINETHICK1;
支撑80.9%:REFDATE(H5,DATE),COLORWHITE;
低:REFDATE(低1,DATE),COLORWHITE;
阻力119.1%:REFDATE(L1,DATE),COLORYELLOW;
阻力138.2%:REFDATE(L2,DATE),COLORMAGENTA;
阻力150%:REFDATE(L3,DATE),COLORLIGRAY;
阻力161.8%:REFDATE(L4,DATE),COLORRED;
阻力180.9%:REFDATE(L5,DATE),COLORWHITE;


DIFF:=EMA(CLOSE,2) - EMA(CLOSE,60);
DEA:=EMA(DIFF,8);


DRAWTEXT(CROSS(DIFF,DEA) AND CROSS("KDJ.K"(9,3,3),"KDJ.D"(9,3,3)),L-0.40,'金叉共振'),COLOR0099FF;
风险系数1:=100*(HHV(HIGH,60)-CLOSE)/(HHV(HIGH,60)-LLV(LOW,60));
风险系数2:=100*(HHV(HIGH,90)-CLOSE)/(HHV(HIGH,90)-LLV(LOW,90));
阶段底部:CROSS(90,风险系数1) AND CROSS(90,风险系数2) AND COUNT(ABS(风险系数1-风险系数2)/风险系数2<0.15,1)=1,NODRAW;

STICKLINE(阶段底部,O,(O+C)/2,3,0),COLORMAGENTA;
A1:=(CLOSE+HIGH+LOW)/3;
A2:=EMA(A1,3);
A3:=REF(A2,1);
A4:=IF(A2>A3,A2,DRAWNULL);
A5:=IF(A2<=A3,A2,DRAWNULL);
STICKLINE(CROSS(C,REF(A5,1)),REF(A5,1)*1.002,REF(A5,1),20,0),COLORRED;
DRAWTEXT(CROSS(REF(A4,1),C) AND A4,H,'↓开跌'),COLORGREEN;

DRAWTEXT_FIX(1,0.00,0,0,'所属行业:')COLOR0080FF;
DRAWTEXT_FIX(1,0.07,0,0,HYBLOCK)COLOR0080FF;
DRAWTEXT_FIX(1,0.14,0,0,'所属地区:')COLOR00FFFF;
DRAWTEXT_FIX(1,0.21,0,0,DYBLOCK)COLOR00FFFF;
DRAWTEXT_FIX(1,0.00,0.06,0,'主题投资:')COLOR0000FF;
DRAWTEXT_FIX(1,0.07,0.06,0,EXTERNVALUE(0,1))COLOR0000FF;
DRAWTEXT_FIX(1,0.00,0.12,0,'概念:')COLOR0000FF;
DRAWTEXT_FIX(1,0.07,0.12,0,EXTERNSTR(0,2))COLOR0000FF;
DRAWTEXT_FIX(1,0.00,0.18,0,'中报业绩:')COLOR0000FF;
DRAWTEXT_FIX(1,0.07,0.18,0,EXTERNSTR(0,3))COLOR0000FF;
DRAWTEXT_FIX(1,0.00,0.24,0,'三季业绩:')COLOR0000FF;
DRAWTEXT_FIX(1,0.07,0.24,0,EXTERNSTR(0,4))COLOR0000FF;
DRAWTEXT_FIX(1,0.00,0.30,0,'盈利预测:')COLOR0000FF;
DRAWTEXT_FIX(1,0.07,0.30,0,EXTERNSTR(0,5))COLOR0000FF;

下载链接:(下载本站资源请点击下面进入下载页“蓝色图标”)

官方千人交流微信群1:rafczx

官方千人交流QQ群8:1500113880




关于我们- 广告合作- 下载声明- 下载帮助- 网站地图- 网站XML- 必应XML- 谷歌XML- 网站TXT- 友情链接- 加入收藏

操盘手公式网   Copyright © 2010-2019   stock87.com™, All Rights Reserved.  浙ICP备17017803号
   免责声明:本站所有信息均免费。所有广告、涉及到的链接,如遇收费行为,均与本站无关!请股友自辨真假.
    本站内容为经验总结,部分源自网络,若无意侵犯了您的版权,请联系我站删除. 广告投放QQ:69948046.


浙ICP备17017803号
微信公众号 回顶部
关闭
关闭
关闭
关闭