股票软件 通达信 大智慧 飞狐 同花顺 东财通 操盘手 指南针 钱龙 券商软件 手机炒股 破解版 证券之星 金融界 分析家 数据下载 数据接口 期货 基金 教程
股票公式 通达信 大智慧 飞狐 同花顺 东财通 | 股票池 通达信 | 大智慧| 股票书籍 | 指标分类 MACD BOLL KDJ OBV CCI RSI DMI SAR VOL DDX DDY DDZ
当前位置:首页 >> 指标公式 >>  公式教程答疑
股票配资开户注册领取2019元现金
牧客农场-注册送50金币
飞狐的周金叉选股公式改成通达信的选股指标
  • 相关简介: 测试已通过
  • 内容标签: 飞狐,周金叉选股公式,通达信,选股指标
  • 浏览次数:
  • 运行环境: Win10,Win8,Win7,WinXP
  • 软件作者: 操盘手公式网
  • 软件来源: www.stock87.com
  • 加入时间: 2019-06-09 23:03:06
  • 解压密码: www.stock87.com(请仔细输入!复制无效!)
软件使用说明:(注:已有源码的公式只需要复制源码,不提供文件下载!)

编写要求:

飞狐的周金叉选股公式改成通达信的选股指标! 并当指标出现“周金叉”和“紫柱”分别做成选股指标

variable:wday[7]='星期六'; wday[1]:='星期日'; wday[2]:='星期一'; wday[3]:='星期二'; wday[4]:='星期三'; wday[5]:='星期四'; wday[6]:='星期五'; fy:=year; fm:=month; fd:=day; wd:=weekday; p:=sysparam(1); str1:='今天是:'+numtostr(fy[p],0)+'年'+numtostr(fm[p],0)+'月' +numtostr(fd[p],0)+'日, '+wday[wd[p]+1]; explain(barpos=p,str1),coloryellow; wr:100*(HHV(HIGH,N)-CLOSE)/(HHV(HIGH,N)-LLV(LOW,N)),coloryellow,linethick2; 80,coloryellow; 20,colorred; 强弱分水岭:50,POINTDOT,colorgreen; 0,colorred,linethick0; 100,colorgreen,linethick1; {PARTLINE(wr<=20,wr),colorgreen,LINETHICK2; PARTLINE(wr>=55 and wr<=80,wr),colorblue,linethick2; PARTLINE(wr<=55 and wr>=20,wr),coloryellow,linethick2; PARTLINE(wr>=80 and wr<100,wr),colorred,linethick2;} RSV:=(CLOSE-LLV(LOW,N1))/(HHV(HIGH,N1)-LLV(LOW,N1))*100; K:SMA(RSV,M1,1)colorred,linethick1; D:SMA(K,M2,1)coloryellow,linethick1; J:3*K-2*D colorgreen,linethick1; FILLRGN(K>=D,K,D),colorred; FILLRGN(KMA(V,10); W2:=MA(C,5)>MA(C,10); {DRAWICON(K>D AND BETWEEN(K,25,50) AND BETWEEN(D,25,50)AND W2 AND W1,L,1);} EXPLAIN(K>D AND BETWEEN(K,25,50) AND BETWEEN(D,25,50)AND W2 AND W1,'三金叉见底,买入,股价脱离底部向上,买入'),coloryellow; Var0004:="KDJ.K#WEEK"(9,3,3); Var0005:="KDJ.D#WEEK"(9,3,3); Var0006:="KDJ.K#MONTH"(9,3,3); Var0007:="KDJ.D#MONTH"(9,3,3); 周金叉: IF(CROSS(Var0004,Var0005),15,0)linestick, color00ff00; 月金叉: IF(CROSS(Var0006,Var0007),20,0)linestick, COLORee99FF; DRAWTEXT(周金叉,16,'周金叉');DRAWTEXT(月金叉,20,'月金叉'); EXPLAIN(EXIST(CROSS(50,WR )AND WRD AND W2 AND W1 AND K<=25,'三金叉见底,买入,股价尚处于底部安全区域,重仓介入'),coloryellow; EXPLAIN( K>=D AND BETWEEN(K,50,80)AND W2 AND W1,'三金叉出现,买入,股价进入主升浪,买入'),colorred; EXPLAIN(K>=D AND D>=75 AND W2 AND W1,'三金叉出现,买入,股价进入风险区轻仓进出,快进快出'),coloryellow; EXPLAIN(K<=D AND K>70 ,'高位死叉,不是洗盘就是下跌,若是洗盘则高抛低吸'),coloryellow; Y1:=C>MA(C,5)AND C>MA(C,10)AND O<ma(c,5)and oD AND K<=20 AND Var0005<25; DRAWTEXT(海底火山,HIGH,'海底火山'),colorgreen; EXPLAIN(海底火山,'海底火山=股价见底,快速买入'),colorred; B:=VAR0004>VAR0005; EXPLAINEX(B,'周K值大于周D值',var0004,2,0),colorff33cc; EXPLAINEX(B,'周D值是',var0005,2,0),colorff33cc; E:=VAR0006>VAR0007; EXPLAINEX(E,'月K值大于D值',var0006,2,0),colorffff00; EXPLAINEX(E,'月D值是',var0007,2,0),colorffff00; M:=K>D AND K>=REF(K,1) ; G:=K<d and="" k=-50,'日K:',K,2,0),colorred; EXPLAINEX(D>=-50,'日D:',D,2,0),colorred; EXPLAINEX(J>=-50,'日J:',J,2,0),colorred; EXPLAIN(M,'日K值金叉日D值,趋势向上'),colorgreen; EXPLAIN(G,'日K值死叉日D值,趋势向下'),coloryellow; j30:"kdj.k#min30"(9,3,3)linethick0; j31:"kdj.d#min30"(9,3,3)linethick0; j60:"kdj.k#min60"(9,3,3)linethick0; j61:"kdj.d#min60"(9,3,3)linethick0; EXPLAINEX(0=0,'30分钟K=',J30,2,0),colorffff00; EXPLAINEX(1=1,'30分钟D=',J31,2,0),colorffff00; EXPLAIN(j30>j31,'30分钟K值金叉日D值,趋势向上'),coloryellow; EXPLAIN(j30<j31,'30分钟k值死叉日d值,趋势向下'),coloryellow; explainex(1="1,'60分钟K=',J60,2,0),colorred;" explain(j6075 AND j61>75,'60分钟K值死叉日D值,趋势向下'),coloryellow; SX:=J30<30 and j31<30 and j60<30 AND j61<30 AND K<20 and D<20; EXPLAIN(j60>j61 ,'60分钟K值金叉日D值,趋势向上'),coloryellow; EXPLAIN(j6075 AND j61>75 AND j3075 AND j31>75 ,'30分钟,60分钟K值全在高位死叉日D值,趋势向下,有一波深幅下跌'),colorff00ff; EXPLAIN(sx,'快进快出,超短线操作')coloryellow; DRAWTEXT(sx,50,'短'),colorgreen; STICKLINE(sx,50,0,0.8,1);

操盘手公式网官方签约公式老师专业解答源码如下

{周金叉}

Var0004:="KDJ.K#WEEK"(9,3,3);
Var0005:="KDJ.D#WEEK"(9,3,3);
周金叉:CROSS(Var0004,Var0005);

下载链接:(下载本站资源请点击下面进入下载页“蓝色图标”)
官方千人交流微信群1:antu1688
官方千人交流微信群2:1500113880



关于我们- 广告合作- 下载声明- 下载帮助- 网站地图- 网站XML- 必应XML- 谷歌XML- 网站TXT- 友情链接- 加入收藏

操盘手公式网   Copyright © 2010-2019   stock87.com™, All Rights Reserved.  浙ICP备17017803号
   免责声明:本站所有信息均免费。所有广告、涉及到的链接,如遇收费行为,均与本站无关!请股友自辨真假.
    本站内容为经验总结,部分源自网络,若无意侵犯了您的版权,请联系我站删除. 广告投放QQ:69948046.


浙ICP备17017803号
微信公众号 回顶部
关闭
关闭
关闭
关闭